ABC Fitness has detected an issue with Insights Analyze and Customize and are Investigating

Incident Report for ABC Fitness

Resolved

Dear Valued Customers,
We are pleased to confirm that Microsoft systems have stabilized and the inconsistent performance issues have been resolved. All services have been restored to full functionality.
We sincerely apologize for any inconvenience this may have caused and appreciate your patience throughout the incident.

Thank you for your continued support.
ABC Fitness Solutions

Reference number: ACC-10016
Posted Oct 21, 2025 - 17:06 CDT

Monitoring

Dear Valued Customers,

We’re pleased to share that ABC Insights dashboards are now operational following Microsoft’s resolution of their global service incident.

At this time, report generation within Insights remains intermittent, and users may experience inconsistent performance when running reports as Microsoft continues to rebalance affected workloads. We will continue working closely with Microsoft until the issue is fully recovers.

Thank you for your continued support.
ABC Fitness Solutions

Reference number: ACC-10016
Posted Oct 21, 2025 - 15:00 CDT

Investigating

ABC has detected an anomaly impacting Insights Analyze and Customize due to an ongoing issue with our third-party vendor, Microsoft.
Our engineering teams have been engaged to confirm any impact and determine the appropriate course of action.
We will provide updates as soon as more information becomes available.

Thank you for your patience.
Posted Oct 21, 2025 - 10:34 CDT
This incident affected: IGNITE (Insights Analyze, Insights Customize).