Dear Valued Customers, We are pleased to confirm that the third‑party issue impacting the applications listed below has been resolved. All services have been successfully restored to full functionality, and our systems are operating normally.
Thank you for your continued support. ABC Fitness Solutions
Posted Apr 25, 2026 - 06:05 CDT
Update
We are seeing initial recovery of Insights applications as services are restored by Microsoft. Users are regaining access and the ability to run reports.
We are continuing to monitor closely to ensure stability and will provide further updates as needed.
Thank you for your patience.
Posted Apr 24, 2026 - 17:52 CDT
Monitoring
Microsoft has confirmed an ongoing incident impacting the Americas, which is affecting Insights applications. At this time, users are still unable to access the applications or run reports.
Microsoft is actively working to resolve the issue. We are closely monitoring the situation and will provide updates as more information becomes available.
Thank you for your patience.
Posted Apr 24, 2026 - 17:34 CDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 24, 2026 - 16:45 CDT
Identified
We are currently investigating an issue impacting the Insights applications due to an ongoing incident with our third party vendor Microsoft. At this time, users are unable to access the applications or run reports.
Our team is actively working with Microsoft to resolve the issue and restore service as quickly as possible. We will share updates as more information becomes available.
Thank you for your patience.
Posted Apr 24, 2026 - 16:37 CDT
This incident affected: Glofox (Insights) and IGNITE (Insights Analyze, Insights Customize).