Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 20, 2026 - 03:00 CST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 16, 2026 - 12:05 CST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 16, 2026 - 12:04 CST
Scheduled
We will be performing planned maintenance on January 20, 2026, from 3:00 AM to 4:00 AM CST
During this time, the following reporting services may be temporarily unavailable:
- Glofox dashboard reports
- Insights and Internal reporting
This maintenance involves a planned restart of the Glofox data warehouse. No action is required from customers, and all services are expected to return to normal once the maintenance is complete.
We appreciate your patience and understanding.
Posted Jan 16, 2026 - 11:40 CST
This scheduled maintenance affected: Glofox (Application Portal, Insights).