ABC Fitness has detected an issue with Trainerize and are Investigating

Incident Report for ABC Fitness

Monitoring

A fix has been implemented, and our teams are currently monitoring the application(s) to ensure stability and performance are fully restored. We will continue to observe system behavior closely before confirming resolution.

We appreciate your patience as we validate the fix.
Posted Jun 18, 2026 - 10:36 CDT

Investigating

ABC has detected an anomaly that may indicate a potential issue affecting the Trainerize & Ignite Engagement. Our engineering teams have been engaged to determine the appropriate course of action. We will provide updates as soon as more information becomes available. Thank you for your patience.
Posted Jun 18, 2026 - 10:27 CDT
This incident affects: Trainerize (Mobile app, Web APP, API Services) and IGNITE (Engagement).